Post Applies to : Plesk for Windows

Plesk 7.5.5 and higher versions support this version of PHP but they are not able to manage PHP4 and PHP5 at the same time; only PHP4 or PHP5.
If your Plesk version is 7.5.5 or higher you can follow these steps to install PHP5 on your server:

1. Download PHP5 Windows Binaries www. php.net/downloads.php:
▪ PHP 5.x.x zip package
▪ Collection of PECL modules for PHP 5.x.x
▪ PHP 5.x.x installe

2. Go to "%plesk_dir%Additional"

3. Rename folder `php` to `php4`.

4. Re-register web service extensions for PHP4.
IIS Management > Web Service Extensions > PHP Extensions > Remove an existing PHP extensions.

Add "%plesk_dir%\Additional\php4\php.exe" and "%plesk_dir%\Additional\php4\sapi\php4isapi.dl l"
5. Backup or rename C:\Windows\php.ini.
6. Launch PHP 5 installer.
7. Select type of installation: Standard.
8. Choose destination folder: %plesk_dir%Additional\php. Otherwise PHP will not be detected by Plesk.
9. Select type of the HTTP server: None.
10. Unzip PHP 5.x.x package into %plesk_dir%Additional\php.
11. Unzip Collection of PECL modules into %plesk_dir%Additional\php\ext.
12. Register PHP5 extension in IIS Web Server manually:
13.
IIS Management > Web Service Extensions > PHP Extensions

* Add "%plesk_dir%\Additional\php\php-cgi.exe" Add "%plesk_dir%\Additional\php\php5isapi.dll"
For example:
C:\Program Files\SWsoft\Plesk\Additional\php\php-cgi.exeC:\Program Files\SWsoft\Plesk\Additional\php\php5isapi.dll
14. PHP5 installer overwrites the file C:\Windows\php.ini therefore, it’s necessary to reconfigure this file according to the Plesk configuration.

Set parameters:

extension_dir = "%plesk_dir%Additional\Php\ext"session.save_pa th = %SystemRoot%temp
upload_tmp_dir = %SystemRoot%temp
For example:
extension_dir ="C:\Program Files\SWsoft\Plesk\Additional\Php\ext"session.save _path = C:\Windows\temp
upload_tmp_dir = C:\Windows\temp

15. Re-configure webmail in IIS Web Server to use PHP4 because HORDE webmail does not work on PHP5.
IIS Management > Web Sites > webmail(default) > Properties > Home Directory tab > Configuration button > Application Extensions > edit value for `.php` extension > set to "%plesk_dir%\additional\php4\php.exe"
Edit "%plesk_vhosts%\webmail\horde\php.ini"

Change parameter:

extension_dir = "%plesk_dir%Additional\Php4\extensions"

For example:

extension_dir ="C:\Program Files\SWsoft\Plesk\Additional\Php4\


16.Reconfigure domains’ web-sites in IIS Web Server to use PHP5.

%plesk_bin%\websrvmng.exe” -–reconfigure-all
After these changes Plesk should start to use PHP5 on your server.

------------------------
Best Regards,
UKShane
http://www.eukhost.com